Saturday, June 05, 2010

PPPoE - config example.

Thanks to Oliver P. from Cisco TAC for this one.

Yet another configuration I keep to quickly test PPPoE or particular features over PPPoE on Cisco routers.

Server
-----------
aaa new-model
!
aaa authentication ppp default local
!
virtual-template 1 pre-clone 20
!
user cisco password cisco
!
bba-group pppoe global
 virtual-template 1
!
interface faX/Y
 pppoe enable
!
interface Loopback0
 ip address 6.6.66.66 255.255.255.255
!
interface Virtual-Template1
 ip unnumbered Loopback0
 peer default ip address pool mypool
 no keepalive
 ppp authentication pap
!
ip local pool mypool 66.66.66.66 66.66.66.166
-----------
Client
-----------
bba-group pppoe global

int  faX/Y
 description PPPOE interface
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
!
interface Dialer1
 mtu 1454
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no keepalive
 ppp authentication pap callin
 ppp pap sent-username cisco password 0 cisco
 ppp ipcp dns request accept
!
!
dialer-list 1 protocol ip permit
!
ip route 0.0.0.0 0.0.0.0 dialer1
-----------

2 comments:

Anonymous said...

Since you explain many subjects in network field, I want to ask you my question related to “site selection in distributed data centers”. The scenario is :
A customer has three sites and offers financial applications with IP services.
The customer uses ACE for load balancing between servers in each site and I’m looking for the best solution for site selection between data centers?
Since the customer uses “Financial applications with IP services”, should I use Cisco GSS and enabling Route Health Injection (RHI) on them??
I’m looking forward to hearing from you ASAP.
Warm regards
Yeganeh

Isam said...

Yeganeh,

GCC and ACE are beyond the scope of my knowledge, beyond the concepts.

That being said there is no uniform solution that would be THE best solution.
http://www.cisco.com/en/US/docs/solutions/Enterprise/Data_Center/dcstslt.html#wp52821

I would suggest you to open thread on supportforums.cisco.com

https://supportforums.cisco.com/community/netpro/data-center/application-network